import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d[ \\-.)]{0,3}){11,20}|(\\b[\\d]{3}\\b)[^,.]";
final String string = "1546\n"
+ "4 8 6 2 6 4 1 1 5 3 6 6 6 7 7 1\n"
+ "5378 2052 1163 1153\n"
+ "6011-7614 4775 1364\n"
+ "333 112,55 mdsksajfk\n\n"
+ "05536080\n\n"
+ "214\n"
+ "12/05\n"
+ "12/08\n\n"
+ "122sss 222222222222111 22464 222 222ss, 222,22 22.22 333215122 22 33 123456789012\n"
+ "122.44\n"
+ "445\n"
+ "1546\n"
+ "4 8 6 2 6 4 1 1 5 3 6 6 6 7 7 1\n"
+ "5378 2052 1163 1153\n"
+ "6011-7614 4775 1364\n"
+ "333 112,55 mdsksajfk\n\n"
+ "11947285580\n"
+ "(11)947285580\n"
+ "1194728-5580\n"
+ "11 94728 5580\n\n"
+ "346.549.668-32\n"
+ "46254966832\n"
+ "31604523875\n"
+ "10154511,55\n"
+ "12/56/12019";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}