#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d[ \-.)]{0,3}){11,20}|(\b[\d]{3}\b)[^,.]"
Local $sString = "1546" & @CRLF & _
"4 8 6 2 6 4 1 1 5 3 6 6 6 7 7 1" & @CRLF & _
"5378 2052 1163 1153" & @CRLF & _
"6011-7614 4775 1364" & @CRLF & _
"333 112,55 mdsksajfk" & @CRLF & _
"" & @CRLF & _
"05536080" & @CRLF & _
"" & @CRLF & _
"214" & @CRLF & _
"12/05" & @CRLF & _
"12/08" & @CRLF & _
"" & @CRLF & _
"122sss 222222222222111 22464 222 222ss, 222,22 22.22 333215122 22 33 123456789012" & @CRLF & _
"122.44" & @CRLF & _
"445" & @CRLF & _
"1546" & @CRLF & _
"4 8 6 2 6 4 1 1 5 3 6 6 6 7 7 1" & @CRLF & _
"5378 2052 1163 1153" & @CRLF & _
"6011-7614 4775 1364" & @CRLF & _
"333 112,55 mdsksajfk" & @CRLF & _
"" & @CRLF & _
"11947285580" & @CRLF & _
"(11)947285580" & @CRLF & _
"1194728-5580" & @CRLF & _
"11 94728 5580" & @CRLF & _
"" & @CRLF & _
"346.549.668-32" & @CRLF & _
"46254966832" & @CRLF & _
"31604523875" & @CRLF & _
"10154511,55" & @CRLF & _
"12/56/12019"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")