const regex = /^([a-f\d]{32}|[A-F\d]{32})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-f\\d]{32}|[A-F\\d]{32})$', '')
const str = `md5格式(32位)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}