package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([a-f\d]{32}|[A-F\d]{32})$`)
var str = `md5格式(32位)
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}