$re = '/^[a-z0-9]+@[a-z]+\.[a-z]+$/m';
$str = 'leminhhung2132434544@gmail.com
&^&^%%$$(*&*&&leminhhung@gmail.com*&%%*%%&%^&$
&*^^*&^^^^^^leminhhung@gmail.com
leminhhung@gmail.com&*^^*&^^^^^^
leminhhung@gmail.com &*^^*&^^^^^^
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);