using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]+@[a-z]+\.[a-z]+$";
string input = @"leminhhung2132434544@gmail.com
&^&^%%$$(*&*&&leminhhung@gmail.com*&%%*%%&%^&$
&*^^*&^^^^^^leminhhung@gmail.com
leminhhung@gmail.com&*^^*&^^^^^^
leminhhung@gmail.com &*^^*&^^^^^^
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}