re = /([a-z]+):\/\/([^\/]*)\/([^\/]*)\/(.*)\.git/m
str = 'https://gitlab.com/example/test_backend.git'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end