$re = '/([a-z]+):\/\/([^/]*)\/([^/]*)\/(.*)\.git/m';
$str = 'https://gitlab.com/example/test_backend.git';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);