import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\D|^)0+(0|[1-9]+))";
final String string = "0127.00.09.01\n"
+ "107.000.09.01\n"
+ "107.0.70.01\n"
+ "107.9.0.01\n"
+ "23.107.000.09\n"
+ "107.09.0.01\n"
+ "23.0.107.000\n"
+ "23.0.107.00\n"
+ "23.0.0127.01";
final String subst = "$2$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}