using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\D|^)0+(0|[1-9]+))";
string substitution = @"$2$3";
string input = @"0127.00.09.01
107.000.09.01
107.0.70.01
107.9.0.01
23.107.000.09
107.09.0.01
23.0.107.000
23.0.107.00
23.0.0127.01";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}