// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(http(s)?://)?matrix\.to/#/(?P<room_id>[^/]+)(/(?P<event_id>[^/?&#]+))?(?P<qs>([&?](via=[^&]+))*)?").unwrap();
let string = "https://matrix.to/#/!PFcniQbnBEDpZRjAFF:matrix.org/$fJ3mYO2y09VdV5INemzXirpeuBLsKQGquiVA8wJIRmU?via=matrix.org&via=nexy7574.co.uk";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}