import Foundation
let pattern = #"Renamed \S+ to (\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2024-04-07 10:20:06,632 - INFO - Renamed clip_0.mp4 to 20240405_000001_S_002.mp4
2024-04-07 10:20:06,632 - INFO - Renamed clip_1.mp4 to 20240405_000002_S_005.mp4
2024-04-07 10:20:06,632 - INFO - Renamed clip_2.mp4 to 20240405_000003_S_069.mp4
2024-04-07 10:20:06,632 - INFO - Renamed clip_3.mp4 to 20240405_000004_S_040.mp4
2024-04-07 10:20:06,632 - INFO - Renamed clip_4.mp4 to 20240405_000005_S_012.mp4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)