// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Renamed \S+ to (\S+)").unwrap();
let string = "2024-04-07 10:20:06,632 - INFO - Renamed clip_0.mp4 to 20240405_000001_S_002.mp4
2024-04-07 10:20:06,632 - INFO - Renamed clip_1.mp4 to 20240405_000002_S_005.mp4
2024-04-07 10:20:06,632 - INFO - Renamed clip_2.mp4 to 20240405_000003_S_069.mp4
2024-04-07 10:20:06,632 - INFO - Renamed clip_3.mp4 to 20240405_000004_S_040.mp4
2024-04-07 10:20:06,632 - INFO - Renamed clip_4.mp4 to 20240405_000005_S_012.mp4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}