import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d){1}\\t\\t(\\d){1,3}\\%\\s\\t(\\d){1}\\t(\\d){1,3}\\%";
final String string = "Current car character\n"
+ "Power Handling Acceleration\n"
+ "102 107 104\n"
+ "Car character points history\n\n"
+ "Car part Level Action Wear New level New wear\n"
+ "Chassis: 6 96% 6 96%\n"
+ "Engine: 7 100% 7 100%\n"
+ "Front wing: 8 70% 8 70%\n"
+ "Rear wing: 8 75% 8 75%\n"
+ "Underbody: 8 63% 8 63%\n"
+ "Sidepods: 8 91% 8 91%\n"
+ "Cooling: 8 80% 8 80%\n"
+ "Gearbox: 7 82% 7 82%\n"
+ "Brakes: 9 25% 9 25%\n"
+ "Suspension: 8 94% 8 94%\n"
+ "Electronics: 8 78% 8 78%\n\n"
+ "(\\d){1}\\t\\t(\\d){1,3}\\%\\s\\t(\\d){1}\\t(\\d){1,3}\\%";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}