#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d){1}\t\t(\d){1,3}\%\s\t(\d){1}\t(\d){1,3}\%"
Local $sString = "Current car character" & @CRLF & _
"Power Handling Acceleration" & @CRLF & _
"102 107 104" & @CRLF & _
"Car character points history" & @CRLF & _
"" & @CRLF & _
"Car part Level Action Wear New level New wear" & @CRLF & _
"Chassis: 6 96% 6 96%" & @CRLF & _
"Engine: 7 100% 7 100%" & @CRLF & _
"Front wing: 8 70% 8 70%" & @CRLF & _
"Rear wing: 8 75% 8 75%" & @CRLF & _
"Underbody: 8 63% 8 63%" & @CRLF & _
"Sidepods: 8 91% 8 91%" & @CRLF & _
"Cooling: 8 80% 8 80%" & @CRLF & _
"Gearbox: 7 82% 7 82%" & @CRLF & _
"Brakes: 9 25% 9 25%" & @CRLF & _
"Suspension: 8 94% 8 94%" & @CRLF & _
"Electronics: 8 78% 8 78%" & @CRLF & _
"" & @CRLF & _
"(\d){1}\t\t(\d){1,3}\%\s\t(\d){1}\t(\d){1,3}\%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")