$re = '/\s*\d+\-?\d*/';
$str = '18-19
2018';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);