package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*\d+\-?\d*`)
var str = `18-19
2018`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}