re = /((?:(?:https?):\/\/)?(?:\S+(?::\S*)?@)?(?:(?:[a-z0-9][a-z0-9\-]*?[a-z0-9]+)(?:\.(?:[a-z0-9\-])*[a-z0-9]+)*(?:\.(?:[a-z]{2,})(:\d{1,5})?))(?:\/[^\s]*)?)(?:[ ]+[^< ]|\Z|\n)/i
str = 'jkNKLJNLKJASSDNBVKLJAVD http://www.google.com
http://www.google.com
<a href="http://www.w3schools.com">Visit W3Schools.com!</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end