use strict;
my $str = 'jkNKLJNLKJASSDNBVKLJAVD http://www.google.com
http://www.google.com
<a href="http://www.w3schools.com">Visit W3Schools.com!</a>
';
my $regex = qr/((?:(?:https?):\/\/)?(?:\S+(?::\S*)?@)?(?:(?:[a-z0-9][a-z0-9\-]*?[a-z0-9]+)(?:\.(?:[a-z0-9\-])*[a-z0-9]+)*(?:\.(?:[a-z]{2,})(:\d{1,5})?))(?:\/[^\s]*)?)(?:[ ]+[^< ]|\Z|\n)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}