$re = '/[\[](.*?)\s|(?<=^|\s)([^=\s]+)="((?:[^\\\\"]|\\\\.)*)/';
$str = '[sig@Sig ver="1" rsID="1\\"234" ... signature="..."][sigSig ver="1" rsID="1\\"234" ... signature="..."]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);