using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\[](.*?)\s|(?<=^|\s)([^=\s]+)=""((?:[^\\""]|\\.)*)";
string input = @"[sig@Sig ver=""1"" rsID=""1\""234"" ... signature=""...""][sigSig ver=""1"" rsID=""1\""234"" ... signature=""...""]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}