import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:[^@\\n]+@)?(?:www\\.)?([^:\\/\\n]+)";
final String string = "http://mplay.google.co.in/sadfask/asdkfals?dk=10\n"
+ "http://lplay.google.co.in/sadfask/asdkfals?dk=10\n"
+ "http://play.google.co.in/sadfask/asdkfals?dk=10\n"
+ "http://tplay.google.co.in/sadfask/asdkfals?dk=10\n"
+ "http://www.google.co.in/sadfask/asdkfals?dk=10\n"
+ "http://www.google.co.in:8080/sadfask/asdkfals?dk=10\n"
+ "http://username:password@hostname/abcd/foo";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}