package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(?:https?:\/\/)?(?:[^@\n]+@)?(?:www\.)?([^:\/\n]+)`)
var str = `http://mplay.google.co.in/sadfask/asdkfals?dk=10
http://lplay.google.co.in/sadfask/asdkfals?dk=10
http://play.google.co.in/sadfask/asdkfals?dk=10
http://tplay.google.co.in/sadfask/asdkfals?dk=10
http://www.google.co.in/sadfask/asdkfals?dk=10
http://www.google.co.in:8080/sadfask/asdkfals?dk=10
http://username:password@hostname/abcd/foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}