// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)https?:\/\/(?:www\.)?([-a-zA-Z0-9@:%._\+~#=]{2,256})(\.[a-z]{2,6}\b)*(\/[\/\d\w\.-]*)*(?:[\?])*(.+)*").unwrap();
let string = "http://wheaton.com/skin/media/main.js
https://wheaton.com/skin/media/main.js
http://www.wheaton.com/skin/media/main.js
https://www.wheaton.com/skin/media/main.js
http://wheaton.com/media/media/main.css
https://wheaton.com/media/media/main.css
http://www.wheaton.com/media/media/main.css
https://www.wheaton.com/media/media/main.css
http://wheaton.com/skin/media/main.png
https://wheaton.com/skin/media/main.jpg
http://www.wheaton.com/skin/media/main.jpeg
https://www.wheaton.com/skin/media/main.gif
http://go.wheaton.com/skin/media/main.png
https://go.wheaton.com/skin/media/main.jpg
http://go.wheaton.com/skin/media/main.jpeg
https://go.wheaton.com/skin/media/main.gif
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}