using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/(?:www\.)?([-a-zA-Z0-9@:%._\+~#=]{2,256})(\.[a-z]{2,6}\b)*(\/[\/\d\w\.-]*)*(?:[\?])*(.+)*";
string input = @"http://wheaton.com/skin/media/main.js
https://wheaton.com/skin/media/main.js
http://www.wheaton.com/skin/media/main.js
https://www.wheaton.com/skin/media/main.js
http://wheaton.com/media/media/main.css
https://wheaton.com/media/media/main.css
http://www.wheaton.com/media/media/main.css
https://www.wheaton.com/media/media/main.css
http://wheaton.com/skin/media/main.png
https://wheaton.com/skin/media/main.jpg
http://www.wheaton.com/skin/media/main.jpeg
https://www.wheaton.com/skin/media/main.gif
http://go.wheaton.com/skin/media/main.png
https://go.wheaton.com/skin/media/main.jpg
http://go.wheaton.com/skin/media/main.jpeg
https://go.wheaton.com/skin/media/main.gif
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}