re = /^(?:T(?:hur|ue)|Wed|Fri|S(?:at|un)|Mon) (?P<date>\d{1,2})$/i
str = 'Thur 21'
# Print the match result
str.match(re) do |match|
puts match.to_s
end