using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:T(?:hur|ue)|Wed|Fri|S(?:at|un)|Mon) (?P<date>\d{1,2})$";
string input = @"Thur 21";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}