$re = '/(:?\+?)[7893]+[0-9() -]{16,17}/';
$str = '+7 (495) 965-14-82';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);