const regex = /(:?\+?)[7893]+[0-9() -]{16,17}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(:?\\+?)[7893]+[0-9() -]{16,17}', '')
const str = `+7 (495) 965-14-82`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}