package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|\s)[a-z]`)
var str = `How can mirrors be real if our eyes aren't real`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}