$re = '/<([A-Z][A-Z0-9]*)\b[^>]*>.*?</\1>/';
$str = '<H1>My First Heading</H1>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);