using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([A-Z][A-Z0-9]*)\b[^>]*>.*?</\1>";
string input = @"<H1>My First Heading</H1>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}