const regex = /^[\x20\t\r\n\f]+|((?:^|[^\\])(?:\\.)*)[\x20\t\r\n\f]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\x20\\t\\r\\n\\f]+|((?:^|[^\\\\])(?:\\\\.)*)[\\x20\\t\\r\\n\\f]+$', 'gm')
const str = `
\\\\
\\\\\\
\\\\\\\\
dfasdf
.some.thing#hi
#boob\\\\s
what\\8
.blah
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);