import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\x20\\t\\r\\n\\f]+|((?:^|[^\\\\])(?:\\\\.)*)[\\x20\\t\\r\\n\\f]+$";
final String string = " \n"
+ "\\\\\n\n"
+ "\\\\\\\n\n"
+ "\\\\\\\\\n\n"
+ "dfasdf\n\n"
+ ".some.thing#hi\n"
+ "#boob\\\\s\n\n"
+ "what\\8\n\n"
+ ".blah\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}