const regex = /(\b0\d*?)0+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b0\\d*?)0+$', 'gm')
const str = `0.24000
4.1100
200
0.100
1.0
00000000
200
230400430000
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);