package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\b0\d*?)0+$`)
var str = `0.24000
4.1100
200
0.100
1.0
00000000
200
230400430000
`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}