$re = '/data-videoid="([^<]*)"/m';
$str = 'data-videoid="eDkYq85r12I"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);