package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)data-videoid="([^<]*)"`)
var str = `data-videoid="eDkYq85r12I"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}