// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"CONN\:.*?prio=(?<severity>\d)\s+id=(?<vmid>\d+).*?event=(?<tag1>\w+)\s+rule=(?<tag2>\w+)\s+conn=(?<tag3>\w+)\s+connipproto=(?<protname>\w+)\s+connrecvif=(?<dinterface>\w+)\s+connsrcip=(?<sip>(\d{1,3}\.){3}\d{1,3})\s+connsrcport=(?<sport>\d+).*?conndestip=(?<dip>(\d{1,3}\.){3}\d{1,3})\s+conndestport=(?<dport>\d+)").unwrap();
let string = "06 12 2017 22:31:35 1.2.1.1 <LOC0:INFO> 1 2017-06-12T22:31:35+02:00 dedusfw EFW - - - CONN: prio=1 id=00600001 rev=1 event=conn_open rule=local_to_nds_dc conn=open connipproto=TCP connrecvif=GESW_vlan2 connsrcip=1.1.1.7 connsrcport=51435 conndestif=G1_vlan253 conndestip=4.1.1.1 conndestport=443
CONN\\:.*?prio=(?<severity>\\d)\\s+id=(?<vmid>\\d+).*?action=(?<action>\\w+).*?rule=(?<tag1>.*?)\\s+recvif=(?<tag2>.*?)\\s+srcip=<sip>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}