const regex = /CONN\:.*?prio=(?<severity>\d)\s+id=(?<vmid>\d+).*?event=(?<tag1>\w+)\s+rule=(?<tag2>\w+)\s+conn=(?<tag3>\w+)\s+connipproto=(?<protname>\w+)\s+connrecvif=(?<dinterface>\w+)\s+connsrcip=(?<sip>(\d{1,3}\.){3}\d{1,3})\s+connsrcport=(?<sport>\d+).*?conndestip=(?<dip>(\d{1,3}\.){3}\d{1,3})\s+conndestport=(?<dport>\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('CONN\\:.*?prio=(?<severity>\\d)\\s+id=(?<vmid>\\d+).*?event=(?<tag1>\\w+)\\s+rule=(?<tag2>\\w+)\\s+conn=(?<tag3>\\w+)\\s+connipproto=(?<protname>\\w+)\\s+connrecvif=(?<dinterface>\\w+)\\s+connsrcip=(?<sip>(\\d{1,3}\\.){3}\\d{1,3})\\s+connsrcport=(?<sport>\\d+).*?conndestip=(?<dip>(\\d{1,3}\\.){3}\\d{1,3})\\s+conndestport=(?<dport>\\d+)', 'g')
const str = `06 12 2017 22:31:35 1.2.1.1 <LOC0:INFO> 1 2017-06-12T22:31:35+02:00 dedusfw EFW - - - CONN: prio=1 id=00600001 rev=1 event=conn_open rule=local_to_nds_dc conn=open connipproto=TCP connrecvif=GESW_vlan2 connsrcip=1.1.1.7 connsrcport=51435 conndestif=G1_vlan253 conndestip=4.1.1.1 conndestport=443
CONN\\:.*?prio=(?<severity>\\d)\\s+id=(?<vmid>\\d+).*?action=(?<action>\\w+).*?rule=(?<tag1>.*?)\\s+recvif=(?<tag2>.*?)\\s+srcip=<sip>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}