$re = '/\"(\w+\-\w+\-\w+)\"/m';
$str = '2022-01-01
"2022-01-01"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);