package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"(\w+\-\w+\-\w+)\"`)
var str = `2022-01-01
"2022-01-01"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}