import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\S+\\s+up\\s+(?<uptime>(?:\\S+\\s+day[s]?,\\s+\\d+:\\d+|\\S+\\s+min)|\\d+:\\d+)";
final String string = " 16:37:50 up 18 days, 19:59, load average: 0.23, 0.26, 0.29\n"
+ " 11:12:08 up 899 days, 20:35, 2 users, load average: 0.28, 0.29, 0.25\n"
+ "11:12:08 up 1 day, 20:35, 2 users, load average: 0.28, 0.29, 0.25\n"
+ " 15:19:17 up 22:45, load average: 0.18, 0.31, 0.36\n"
+ " 11:11:11 up 12:55, 2 users, load averages: 0.00, 0.01, 0.06\n"
+ " 11:11:11 up 55 min, 2 users, load averages: 0.00, 0.01, 0.06\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}