package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*\S+\s+up\s+(?<uptime>(?:\S+\s+day[s]?,\s+\d+:\d+|\S+\s+min)|\d+:\d+)`)
var str = ` 16:37:50 up 18 days, 19:59, load average: 0.23, 0.26, 0.29
11:12:08 up 899 days, 20:35, 2 users, load average: 0.28, 0.29, 0.25
11:12:08 up 1 day, 20:35, 2 users, load average: 0.28, 0.29, 0.25
15:19:17 up 22:45, load average: 0.18, 0.31, 0.36
11:11:11 up 12:55, 2 users, load averages: 0.00, 0.01, 0.06
11:11:11 up 55 min, 2 users, load averages: 0.00, 0.01, 0.06
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}