using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^ ]*) - ([^ ]*) \[(.*)\] \""([^ ]*) ([^ ]*) ([^ ]*)\"" (-|[0-9]*) (-|[0-9]*) \""(.+?|-)\"" ([^ ]*|-) ([^ ]*|-) ([^ ]*|-) \""(.+?|-)\"" \""(.+?|-)\"" \""(.+?|-)\""$";
string input = @"14.23.114.61 - wo.haodou.com [15/Sep/2014:16:34:46 +0800] ""GET /717238/ HTTP/1.1"" 200 4895 ""http://www.haodou.com/recipe/472378"" - 0.034 6ibgu5ha3g8ev3s6vsnf672rq1 ""-"" ""Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36 SE 2.X MetaSr 1.0"" ""0.034""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}