re = /^(2[0-4]\d|25[0-5]|1\d\d|\d\d?)\.(?1)\.(?1)\.(?1)$/m
str = '1.2.3.4
91.9.9.111
0.0.0.0
121.211.233.251
255.255.255.255
121.255.255.256
256.255.255.2
999.999.999.999
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end