package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(2[0-4]\d|25[0-5]|1\d\d|\d\d?)\.(?1)\.(?1)\.(?1)$`)
var str = `1.2.3.4
91.9.9.111
0.0.0.0
121.211.233.251
255.255.255.255
121.255.255.256
256.255.255.2
999.999.999.999
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}