const regex = /(?!^[~!@#$%^&*().]+$)^([\u4e00-\u9fa5]*|[\da-zA-Z~!@#$%^&*.·\s]*){0,30}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^[~!@#$%^&*().]+$)^([\\u4e00-\\u9fa5]*|[\\da-zA-Z~!@#$%^&*.·\\s]*){0,30}$', '')
const str = ` ~!@#\$%^&**hJ电费Dfd s是 的发送 到 · 水电费水`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}