import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!^[~!@#$%^&*().]+$)^([\\u4e00-\\u9fa5]*|[\\da-zA-Z~!@#$%^&*.·\\s]*){0,30}$";
final String string = " ~!@#$%^&**hJ电费Dfd s是 的发送 到 · 水电费水";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}