re = /^https?:\/{2}regex101\.com\/r\/([a-zA-Z0-9]{6})(?:\/(\d+)?)/m
str = 'http://regex101.com/r/mH1fN5
https://regex101.com/r/fW0vZ2
https://regex101.com/r/wY0rM7/3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end